Proxy support.

Es habitual que en el trabajo o en la universidad se acceda a internet a través de un proxy. Puntualizar que solo se permite definir un proxy global, ya que esta funcionalidad no pretende saltarse los limites impuestos por los servicios, sino facilitar el acceso.

2009-04-18-232603_1024x600_scrot

Me gustaría aclarar un detalle sobre el Update Manager, este solo se usa para actualizar o instalar nuevos servicios, siempre y cuando estos sean aun compatibles con la versión de Tucan que se este usando.

Las nuevas versiones hay que instalarlas manualmente. El Update Manager esta diseñado para actualizar los servicios desde el SVN, siendo esta una solución flexible y eficaz, pero no recomendable para actualizar toda la aplicación.

  • Si usas GNU/Linux, próximamente encontraras Tucan en los repositorios oficiales de las principales distribuciones. Entre tanto puedes usar el código fuente, teniendo cuidado con las dependencias, o bien usar el paquete de getdeb.
  • En cambio si usas MS Windows debes descargar el Setup que posibilita la instalación de las dependencias automáticamente.

Finalmente señalar que ahora se comprueba si hay nuevas versiones o actualizaciones al iniciar Tucan y se avisa al intentar cerrar si se tienen descargas activas. Además se han solucionado multitud de bugs.

Están disponibles para descarga tucan-0.3.7 y tucan-0.3.7-win32.  ¡Disfrutadlas!

Un saludo, Crak.

16 comments so far

  1. shakaran on

    Genial, una opción bastante útil😉

  2. Pez on

    Me gusta como avanza el proyecto. Ya quiero ver a Tucan en Debian.

  3. Alberto on

    Soy usuario único de Ubuntu desde sus comienzos, lo tengo instalado en mi ordenador de casa y en mi portátil. Y no había visto un gestor de descargas pensado para manejar bien megaupload o rapidshare.. excelente idea.

    ¡Muchas gracias por vuestro software!

    ¡Yo también quiero Tucan en los repositorios de Ubuntu!

    Un saludo

  4. Korsakoff on

    Enhorabuena, el proyecto está creciendo cada día más.

    Suerte!

  5. Farmer on

    plz support odsiebie.com (translate:fromme.com)

    tucan working great!

  6. marioquartz on

    Yo intento instalarlo en Ubuntu actualizado al maximo. No localiza el paquete de OCR y es imposible instalarlo a mano. Tampoco va con wine. ¿Que estoy haciendo mal?

  7. a-slack on

    Si estas en Ubuntu da igual que instales desde el tarball oficial que desde el paquete.deb que hay en getdeb.net, tienes que resolver las dependencias a mano antes de poder usar Tucan, en tu caso:

    $ sudo aptitude install python2.5 python-gtk2 python-imaging tesseract-ocr tesseract-ocr-eng librsvg2-common

    …y si estas en linux usa la versión para linux, es una aberración que quieras usar la versión para windows de Tucan si estas en linux.

  8. marioquartz on

    El problema es que no puedo instalar de ninguna manera el tesseract-ocr ya que no existe en ningun repositorio. Y aunque he bajado las fuentes no se puede instalar, dado que da errores a mansalva.

    Por tanto no puedo instalar algo que no utiliza algo que no puedo instalar. Por tanto intente usar wine.

    Yo soy practico. Si no va la versión linux, pruebo con la versión windows via wine.

  9. a-slack on

    Todas las dependencias de Tucan estan en los repositorios de Ubuntu cosa que puedes comprobar mirando estas URLs:

    http://packages.ubuntu.com/python2.5
    http://packages.ubuntu.com/python-gtk2
    http://packages.ubuntu.com/python-imaging
    http://packages.ubuntu.com/tesseract-ocr
    http://packages.ubuntu.com/tesseract-ocr-eng
    http://packages.ubuntu.com/librsvg2-common

    Revisa tu archivo /etc/apt/sources.list que tengas todas las secciones de los repositorios de Ubuntu: main universe multiverse restricted. Si no todas por lo menos que tengas las secciones “main” y “universe” pq todas las dependencias estan en “main” menos tesseract-ocr y tesseract-ocr-eng que estan en “universe”.

    Después de añadir las secciones a tu archivo /etc/apt/sources.list:

    $ sudo aptitude update && sudo aptitude install python2.5 python-gtk2 python-imaging tesseract-ocr tesseract-ocr-eng librsvg2-common

  10. felipe on

    muy buena la informacion. voy a intentar instalarlo

  11. Himer on

    Hay un problema con el uso del proxy, en mi caso tengo un proxy al cual acceso con user y password ,
    en la intefaz no encuentro ningun lugar donde se habilite la opcion para user y pass .

    Nota: probe usando el formato estandar
    http://username:password@IP_PROXY y el puerto pero no funciona.

    A los desarrolladores, no se olviden de que hay usuarios con USER y PASSW en los proxys que usan .

    PD : execelente programa lo recomiendo !!

  12. Franco on

    Hola, yo uso tucan en ubunutu 8.10 pero después de descargar el primer enlace tengo que reiniciar el modem a mano porque no continúa descargando. ¿Qué puedo hacer para solucionar esto?

  13. Franco on

    Hola otra vez hice un ejecutable para linux que bootea el modem, pero de todas maneras hay que hacerlo a mano, si les sirve se los paso:

    #!/bin/sh
    # Script de reconexion adsl
    CTRL=” 33[1;32;41m NO CERRAR ESTA VENTANA ”
    sleep 1
    poff dsl-provider
    echo “`date +%x” “%H:%M:%S` ADSL: Se perdio la conexion! ”
    sleep 3
    pon dsl-provider
    done

    Con esto crean un *.sh con el nombre que más les guste y en preferencias de este archivo tilden “permitir ejecutar como un programa”.

    Con este Script yo logro cambiar la ip de mi modem y asi poder seguir bajando todo lo que quiero, no es practico pero por hora lo uso así hasta que pueda darle en la tecla a tucan.
    Saludos a todos.-
    “Sean libres, sean abiertos… sean linux”

  14. victor on

    tengo un problema, instale tucan sobre win xp. funcionaba de 10!
    pero ahora me sale un cartelito que dice esto:

    see the logfile C:\Tucan\tucan.exe.log for details

  15. patricio on

    Hola, quiero usar este programa en ubuntu 10.10, pero cuando me pide checkear los links (RS), me dice que no estàn funcionando, siendo que desde el link original funcionan bien, y descargan. cuàl es el error?
    gracias!!

  16. Toni on

    ¿Qué hacemos con los proxy que requieren usuario y password para la autentificación del usuario? ¿Existe alguna forma de introducir los datos del usuario para su identificación por el proxy? Si no es así ¿se tiene previsto realizar una actualización de TUCAN que permita esta operatividad? GRACIAS Y UN SALUDO.


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: